Upgrading to the latest Multilizer version

If you are using Multilizer Software Localization components in any old Multilizer version, please check the migration path here.

Upgrading from Multilizer 2007 - 2011 to latest Multilizer

  • Simply open your existing Multilizer project in the latest Multilizer and you're done!

Upgrading from Multilizer 6.x to latest Multilizer

  • Use the Mpr2M7p tool to convert the existing Multilizer 6.x to the latest Multilizer project format.
  • If you don't have this tool, please contact support(at)multilizer.com to get it.

Upgrading from Multilizer 5.x to latest Multilizer

  • Please follow the steps below to upgrade your Multilizer 5.x and 6.x projects to latest Multilizer. If you have a Delphi/C++Builder component localization project to update, check out Mpr5ToM7p tool


3 steps to quick upgrade

  1. Create a new project with Multilizer 2011. File->New... or File->New from template...
    • Select the first file to localize
    • Select desired target languages
  2. (Optional) Add more files to localize in the project. Project->Add target...
  3. Import existing translations from Multilizer 5.x or 6.x project. File->Import...
    • Choose "Import from other formats"
    • Select MPR
    • Continue as guided by the Import Wizard


Fine tuning

The following features have been further developed in Multilizer. Check out these to get maximum benefit of the new productivity and quality features.

  • Configure the way that Multilizer scans and builds files; select desired target and choose Project->Edit target...
  • Ensure maximum re-use of old translations; configure Assisted Translation Expert so that it automatically suggests translations for any native string.
  • Exclude strings that you don't need to localize;
    • right-click a row, and choose from the exclude options there.
    • right-click a node, and exclude multiple rows at once.
    • fine-tune excludes, Project->Excluded strings...
  • Mark strings as read-only, if needed.
  • Run Quality Expert to detect possible issues.
  • Use Productivity Expert to achieve higher translation consistency with less work.

Recap of new and improved features

  • Localization Templates (File->New from template...); simplifies creation of new localization projects.
  • Assisted Translation Expert for easier use of existing translations
  • Exclude strings with wildcards
  • Quality Expert; new validations and color codes in string grid for issues.
  • Productivity Expert; more efficient propagation of translations.
  • More...